The goal of this project is to make virtual world a safer and better place without child pornography, major computer crime and RIAA.
Login As
You can log in if you are registered at one of these services:
Security Bulletins
Latest Malware Updates

Infostealer.Posteal

02/26/2015

Downloader.Busadom

02/26/2015

Trojan.Ladocosm

02/26/2015

SONAR.SuspDocRun

02/25/2015

SONAR.SuspHelpRun

02/25/2015

PHP CGI vulnerability is being massively exploited

PHP CGI vulnerability is being massively exploited

According to cybersecurity experts the PHP CGI-based setups vulnerability is actively being exploited by the cybercrooks. The vulnerability was found back in January 2012 during Nullcon CTF. On May 04 PHP devs released patches and a workaround. Just within a week another patch was released that eliminated additional attack vectors.

Trustwave says the flaw is being massively used in order to create a backdoor in vulnerable systems. DreamHost that hosts more than 1 million domains provided Trustwave’s SpiderLabs with security logs related to o PHP-CGI exploit attempts. The information extracted from the logs indicate that each 5-th domain is being attacked with different vector exploits.

One of the interesting aspects of the exploit code is the section where attacker tries to prevent other people from using the vulnerability.

'<IfModule mod_rewrite.c>'.chr(10).
'RewriteEngine On'.chr(10).
'RewriteCond %{QUERY_STRING} ^(%2d|-)[^=]+$ [NC]'.chr(10).
'RewriteRule ^(.*) $1? [L]'.chr(10).
'</IfModule>'.

These are mod_rewrite rules that are added to .htaccess as crude method of patching the vuknerability.

“Due to the fact that attackers are actively probing for this vulnerability combined with PHP code fixes that may not be complete, you should consider deploying some security filters in the interim” Trustwave experts say.

Trustwave advisory is accessible here.

(c) Naked Security


Security Advisories Database

Remote Code Execution Vulnerability in Microsoft OpenType Font Driver

A remote attacker can execute arbitrary code on the target system.

07/21/2015

SQL Injection Vulnerability in Piwigo

SQL inection vulnerability has been discovered in Piwigo.

02/05/2015

Cross-site Scripting Vulnerability in DotNetNuke

A cross-site scripting (XSS) vulnerability has been discovered in DotNetNuke.

02/05/2015

Cross-site Scripting Vulnerability in Hitachi Command Suite

A cross-site scripting vulnerability was found in Hitachi Command Suite.

02/02/2015

Denial of service vulnerability in FreeBSD SCTP RE_CONFIG Chunk Handling

An attacker can perform a denial of service attack.

01/30/2015

Denial of service vulnerability in Apache Traffic Server HTTP TRACE Max-Forwards

An attacker can perform a denial of service attack.

01/30/2015

Denial of service vulnerability in MalwareBytes Anti-Exploit &quot;mbae.sys&quot;

An attacker can perform a denial of service attack.

01/30/2015

Denial of service vulnerability in Linux Kernel splice

An attacker can perform a denial of service attack.

01/29/2015

Denial of service vulnerability in Python Pillow Module PNG Text Chunks Decompression

An attacker can perform a denial of service attack.

01/20/2015